Commit c969982e authored by Piotr Gawron's avatar Piotr Gawron
Browse files

debian package requires openjdk instead of oracle-jdk

parent ed593917
minerva (13.0.0) stable; urgency=medium
* Bug fix: Since Oracle Java cannot be installed as debian dependency we use
openjdk-8. Due to this dependency minerva can be no longer installed on
Ubuntu-14 (#223)
-- Piotr Gawron <piotr.gawron@uni.lu> Mon, 6 May 2019 18:00:00 +0200
minerva (12.2.3) stable; urgency=medium
* Bug fix: sorting of entries in "Edit project->overlays" dialog fixed (#790)
* Bug fix: searching of chemicals stopped working due to expired SSL
......
......@@ -13,4 +13,4 @@ Description: Standalone web application for visualization, exploration and
Tomcat server later to change the address.
Section: science
Homepage: http://r3lab.uni.lu/web/minerva-website/
Depends: ${misc:Depends}, tomcat7 | tomcat8, oracle-java8-set-default, postgresql (>=9.3)
Depends: ${misc:Depends}, openjdk-8-jre-headless, tomcat7 | tomcat8, postgresql (>=9.3)
......@@ -14,14 +14,6 @@ log "Running preinst" $1 $2;
# we execute it here because if some packages are missing then dpkg will return non-zero exit code
set -e
DEFAULT_JAVA_SYMLINK="/usr/lib/jvm/default-java"
log "changing \$DEFAULT_JAVA_SYMLINK";
path="/usr/lib/jvm/java-8-oracle";
log "Creating symlink between $path and $DEFAULT_JAVA_SYMLINK";
rm -f $DEFAULT_JAVA_SYMLINK
ln -s $path $DEFAULT_JAVA_SYMLINK
case "$1" in
install|upgrade)
invoke-rc.d $TOMCAT_PACKAGE stop || true
......
......@@ -3307,6 +3307,12 @@
}
}
},
"log4js-memory-appender": {
"version": "1.0.5",
"resolved": "https://registry.npmjs.org/log4js-memory-appender/-/log4js-memory-appender-1.0.5.tgz",
"integrity": "sha1-e4I2NDpCuLEgidjX+kebD22aNME=",
"dev": true
},
"longest": {
"version": "1.0.1",
"resolved": "https://registry.npmjs.org/longest/-/longest-1.0.1.tgz",
......@@ -5072,15 +5078,6 @@
}
}
},
"stream-to-blob": {
"version": "1.0.1",
"resolved": "https://registry.npmjs.org/stream-to-blob/-/stream-to-blob-1.0.1.tgz",
"integrity": "sha512-aRy4neA4rf+qMtLT9fCRLPGWdrsIKtCx4kUdNTIPgPQ2hkHkdxbViVAvABMx9oRM6yCWfngHx6pwXfbYkVuPuw==",
"dev": true,
"requires": {
"once": "^1.3.3"
}
},
"streamroller": {
"version": "1.0.4",
"resolved": "https://registry.npmjs.org/streamroller/-/streamroller-1.0.4.tgz",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment