Commit c54b7636 authored by Jacek Lebioda's avatar Jacek Lebioda
Browse files

Resolve "Add version 0.3.2 of the theme"

parent 22f0585a
...@@ -3,7 +3,7 @@ source "https://rubygems.org" ...@@ -3,7 +3,7 @@ source "https://rubygems.org"
gem "jekyll", "~> 4.0" gem "jekyll", "~> 4.0"
gem "bundler", "> 2.0" gem "bundler", "> 2.0"
gem "minima", "~> 2.5" gem "minima", "~> 2.5"
gem 'jekyll-theme-lcsb-default', '~> 0.3.0', :git => "https://git-r3lab.uni.lu/core-services/jekyll-theme-lcsb-default.git", :tag => "0.3.0" gem 'jekyll-theme-lcsb-default', '~> 0.3.2', :git => "https://git-r3lab.uni.lu/core-services/jekyll-theme-lcsb-default.git", :tag => "0.3.2"
group :jekyll_plugins do group :jekyll_plugins do
gem "jekyll-paginate-v2", "~> 2", gem "jekyll-paginate-v2", "~> 2",
......
GIT GIT
remote: https://git-r3lab.uni.lu/core-services/jekyll-theme-lcsb-default.git remote: https://git-r3lab.uni.lu/core-services/jekyll-theme-lcsb-default.git
revision: f3673bc3e1faa444079a6e89269c9d6035d14bc4 revision: 79738a9ef7f9a714a95a835e9d0d8ad790d7e4a4
tag: 0.3.0 tag: 0.3.2
specs: specs:
jekyll-theme-lcsb-default (0.3.0) jekyll-theme-lcsb-default (0.3.2)
jekyll (~> 4.0) jekyll (~> 4.0)
jekyll-seo-tag (~> 2.5) jekyll-seo-tag (~> 2.5)
...@@ -25,10 +25,10 @@ GEM ...@@ -25,10 +25,10 @@ GEM
eventmachine (>= 0.12.9) eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0) http_parser.rb (~> 0.6.0)
eventmachine (1.2.7-x64-mingw32) eventmachine (1.2.7-x64-mingw32)
ffi (1.11.1-x64-mingw32) ffi (1.12.2-x64-mingw32)
forwardable-extended (2.6.0) forwardable-extended (2.6.0)
http_parser.rb (0.6.0) http_parser.rb (0.6.0)
i18n (1.7.0) i18n (1.8.2)
concurrent-ruby (~> 1.0) concurrent-ruby (~> 1.0)
jekyll (4.0.0) jekyll (4.0.0)
addressable (~> 2.4) addressable (~> 2.4)
...@@ -45,9 +45,9 @@ GEM ...@@ -45,9 +45,9 @@ GEM
rouge (~> 3.0) rouge (~> 3.0)
safe_yaml (~> 1.0) safe_yaml (~> 1.0)
terminal-table (~> 1.8) terminal-table (~> 1.8)
jekyll-feed (0.12.1) jekyll-feed (0.13.0)
jekyll (>= 3.7, < 5.0) jekyll (>= 3.7, < 5.0)
jekyll-sass-converter (2.0.1) jekyll-sass-converter (2.1.0)
sassc (> 2.0.1, < 3.0) sassc (> 2.0.1, < 3.0)
jekyll-seo-tag (2.6.1) jekyll-seo-tag (2.6.1)
jekyll (>= 3.3, < 5.0) jekyll (>= 3.3, < 5.0)
...@@ -57,7 +57,7 @@ GEM ...@@ -57,7 +57,7 @@ GEM
kramdown-parser-gfm (1.1.0) kramdown-parser-gfm (1.1.0)
kramdown (~> 2.0) kramdown (~> 2.0)
liquid (4.0.3) liquid (4.0.3)
listen (3.2.0) listen (3.2.1)
rb-fsevent (~> 0.10, >= 0.10.3) rb-fsevent (~> 0.10, >= 0.10.3)
rb-inotify (~> 0.9, >= 0.9.10) rb-inotify (~> 0.9, >= 0.9.10)
mercenary (0.3.6) mercenary (0.3.6)
...@@ -67,21 +67,21 @@ GEM ...@@ -67,21 +67,21 @@ GEM
jekyll-seo-tag (~> 2.1) jekyll-seo-tag (~> 2.1)
pathutil (0.16.2) pathutil (0.16.2)
forwardable-extended (~> 2.6) forwardable-extended (~> 2.6)
public_suffix (4.0.1) public_suffix (4.0.3)
rb-fsevent (0.10.3) rb-fsevent (0.10.3)
rb-inotify (0.10.0) rb-inotify (0.10.1)
ffi (~> 1.0) ffi (~> 1.0)
rouge (3.12.0) rouge (3.15.0)
safe_yaml (1.0.5) safe_yaml (1.0.5)
sassc (2.2.1-x64-mingw32) sassc (2.2.1-x64-mingw32)
ffi (~> 1.9) ffi (~> 1.9)
terminal-table (1.8.0) terminal-table (1.8.0)
unicode-display_width (~> 1.1, >= 1.1.1) unicode-display_width (~> 1.1, >= 1.1.1)
tzinfo (2.0.0) tzinfo (2.0.1)
concurrent-ruby (~> 1.0) concurrent-ruby (~> 1.0)
tzinfo-data (1.2019.3) tzinfo-data (1.2019.3)
tzinfo (>= 1.0.0) tzinfo (>= 1.0.0)
unicode-display_width (1.6.0) unicode-display_width (1.6.1)
wdm (0.1.1) wdm (0.1.1)
PLATFORMS PLATFORMS
...@@ -92,7 +92,7 @@ DEPENDENCIES ...@@ -92,7 +92,7 @@ DEPENDENCIES
jekyll (~> 4.0) jekyll (~> 4.0)
jekyll-feed (~> 0.6) jekyll-feed (~> 0.6)
jekyll-paginate-v2 (~> 2)! jekyll-paginate-v2 (~> 2)!
jekyll-theme-lcsb-default (~> 0.3.0)! jekyll-theme-lcsb-default (~> 0.3.2)!
minima (~> 2.5) minima (~> 2.5)
tzinfo-data tzinfo-data
wdm (~> 0.1.1) wdm (~> 0.1.1)
......
...@@ -2,10 +2,11 @@ ...@@ -2,10 +2,11 @@
A Docker base-image containing Ruby dependencies for Jekyll instances using Jekyll-LCSB-Theme. A Docker base-image containing Ruby dependencies for Jekyll instances using Jekyll-LCSB-Theme.
# Versions # Versions
| Tag | Jekyll version | Bundler version | | Tag | Jekyll version | Bundler version | Theme version |
|:-----------------:|:--------------:|-----------------| |:-----------------:|:--------------:|-----------------|---------------|
| 1.0 (or latest) | Jekyll 4.0.0 | 2.0.2 | | 1.1 (or latest) | Jekyll 4.0.0 | 2.0.2 | 0.3.2 |
| 0.1 (or legacy) | Jekyll 3.8.6 | 1.17.3 | | 1.0 | Jekyll 4.0.0 | 2.0.2 | 0.3.0 |
| 0.1 (or legacy) | Jekyll 3.8.6 | 1.17.3 | 0.2.X |
# How to use? # How to use?
In your `.gitlab-ci.yml` file add the following line (make sure `r3` is written in lower-case): In your `.gitlab-ci.yml` file add the following line (make sure `r3` is written in lower-case):
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment