Commit 9680a083 authored by Jacek Lebioda's avatar Jacek Lebioda
Browse files

feat: upgrade to 1.2

parent 9669656f
......@@ -6,7 +6,7 @@ gem "minima", "~> 2.5"
gem 'jekyll-theme-lcsb-default', '~> 0.3.3', :git => "https://git-r3lab.uni.lu/core-services/jekyll-theme-lcsb-default.git", :tag => "0.3.3"
group :jekyll_plugins do
gem "jekyll-paginate-v2", "~> 2",
gem "jekyll-paginate-v2", "~> 3",
:git => "https://github.com/sverrirs/jekyll-paginate-v2.git"
gem "jekyll-feed", "~> 0.6"
end
......
......@@ -9,9 +9,9 @@ GIT
GIT
remote: https://github.com/sverrirs/jekyll-paginate-v2.git
revision: f8664cf68b59de823b88d4e6b1b985457f2c13af
revision: 0e149fddb9a93161e8e9e9cf42d34aee493d768c
specs:
jekyll-paginate-v2 (2.1.0)
jekyll-paginate-v2 (3.0.0)
jekyll (>= 3.0, < 5.0)
GEM
......@@ -20,11 +20,13 @@ GEM
addressable (2.7.0)
public_suffix (>= 2.0.2, < 5.0)
colorator (1.1.0)
concurrent-ruby (1.1.5)
concurrent-ruby (1.1.6)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
eventmachine (1.2.7)
eventmachine (1.2.7-x64-mingw32)
ffi (1.12.2)
ffi (1.12.2-x64-mingw32)
forwardable-extended (2.6.0)
http_parser.rb (0.6.0)
......@@ -71,8 +73,10 @@ GEM
rb-fsevent (0.10.3)
rb-inotify (0.10.1)
ffi (~> 1.0)
rouge (3.15.0)
rouge (3.16.0)
safe_yaml (1.0.5)
sassc (2.2.1)
ffi (~> 1.9)
sassc (2.2.1-x64-mingw32)
ffi (~> 1.9)
terminal-table (1.8.0)
......@@ -82,20 +86,19 @@ GEM
tzinfo-data (1.2019.3)
tzinfo (>= 1.0.0)
unicode-display_width (1.6.1)
wdm (0.1.1)
PLATFORMS
ruby
x64-mingw32
DEPENDENCIES
bundler (> 2.0)
jekyll (~> 4.0)
jekyll-feed (~> 0.6)
jekyll-paginate-v2 (~> 2)!
jekyll-paginate-v2 (~> 3)!
jekyll-theme-lcsb-default (~> 0.3.3)!
minima (~> 2.5)
tzinfo-data
wdm (~> 0.1.1)
BUNDLED WITH
2.0.2
2.1.4
......@@ -4,9 +4,10 @@ A Docker base-image containing Ruby dependencies for Jekyll instances using Jeky
# Versions
| Tag | Jekyll version | Bundler version | Theme version |
|:-----------------:|:--------------:|-----------------|---------------|
| 1.1 (or latest) | Jekyll 4.0.0 | 2.0.2 | 0.3.3 |
| 1.2 (or latest) | Jekyll 4.0.0 | 2.0.2 | 0.3.3 |
| 1.1 | Jekyll 4.0.0 | 2.0.2 | 0.3.3 |
| 1.0 | Jekyll 4.0.0 | 2.0.2 | 0.3.0 |
| 0.1 (or legacy) | Jekyll 3.8.6 | 1.17.3 | 0.2.X |
| 0.1 (or legacy) | Jekyll 3.8.6 | 1.17.3 | 0.3.0 |
# How to use?
In your `.gitlab-ci.yml` file add the following line (make sure `r3` is written in lower-case):
......@@ -22,7 +23,8 @@ image: git-r3lab.uni.lu:4567/r3/docker/jekyll-lcsb:0.1
Run:
```
docker build -t git-r3lab.uni.lu:4567/r3/docker/jekyll-lcsb:new_tag . # replace `new_tag` with e.g. 1.1
# replace `new_tag` with e.g. 1.3, and don't forget the dot...
docker build -t git-r3lab.uni.lu:4567/r3/docker/jekyll-lcsb:new_tag . # ...there
docker build -t git-r3lab.uni.lu:4567/r3/docker/jekyll-lcsb:latest .
```
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment